Differences

This shows you the differences between two versions of the page.

Link to this comparison view

grml_glt06 [2011/10/13 23:55] (current)
Line 1: Line 1:
 +======  Issues regarding grml GLT06 edition ======
  
 +===== Differences to grml 0.7 =====
 +
 +  * fixed [[grml_0.7|known issues from grml 0.7]]
 +  * updated packages to Debian unstable pool by 15th of May
 +  * X.org 7.0
 +  * added support for vodafone UMTS cards (A1/T-Mobile), see 'grml-tips umts'
 +  * added support for [[http://michael-prokop.at/blog/2006/05/14/using-targus-wireless-multimedia-presenter-with-linux/|Targus Presenter]]
 +  * added grml-resolution: change X resolution via a simple menu frontend
 +  * new default font (Lat15-Terminus16) on plain console 
 +  * added scripts blacklist + unblacklist: [un]blacklist a specific kernelmodule during runtime via /etc/modprobe.d/grml
 +  * reworked grml-network
 +  * grml-postfix: reworked, now executing 'dpkg-reconfigure postfix'
 +  * grml-autoconfig interface: read in already set values so the current configuration is visible to the user
 +  * grml-x completion: check for present window-managers and don't use a static list
 +  * added /etc/rc{0..6}.d/ /etc/rcS.d directories with important_notice to inform users about file-rc.
 +  * added support for latin2 fonts on plain console
 +  * reworked XF86Audio* scripts
 +  * support multiline settings in /cdrom/bootparams/*.
 +  * grml-tpm: set up a system for use with TPM technology via tpm-emulator
 +  * grml2hd: added support for setting hostname through script 'grml-hostname'
 +  * [[http://grml.supersized.org/archives/154-reworked-grml2hd-utils,-improved-grml2hd.html|reworked grml2hd-utils]]
 +  * setup of files in /boot/grub/ to be able to install grub; provide sample menu.lst for use with grml2hd - see 'grml-tips grub'
 +
 +  * new packages (excluding lib* and xserver-stuff):
 +
 +<code>
 +aircrack-ng btscanner cdck cedet-common classpath classpath-common cpuid
 +debian-goodies fvwm fvwm-crystal gconf2-common grep-dctrl habak jamvm jikes
 +lspowertweak mktemp mysql-client-5.0 ndiswrapper-common ndiswrapper-utils-1.7
 +ndiswrapper-utils-1.8 openafs-modules-2.6.16-grml pktstat powertweak-gtk
 +powertweakd pymacs python-minimal python-mode remind tpm-emulator-modules-2.6.16-grml
 +tpm-tools trayer trousers tzdata unionfs-tools wpagui wyrd</code>
 +
 +  * removed packages (excluding lib*):
 +
 +<code>
 +aide antlr apachetoolbox ccdv cpudyn debfoster eagle-usb-data eagle-usb-modules-2.6.16-grml
 +eagle-usb-utils ecj-bootstrap edictionary fastjar fcheck ftester gcj-4.0-base giftrans
 +gij-4.0 gjdoc hgrep httpf ices2 isdnutils-xtools kaffe kaffe-common kaffe-pthreads
 +lbxproxy m-tx mg musixtex mwcollect mysql-client-4.1 ooo2dbk proftpd-common proxymngr
 +qtparted shunit tiger vncserver xfree86-driver-synaptics xfwp xmon xprint xprint-common
 +xserver-common</code>
 +
 +===== Bugs/Problems =====
 +
 +You found a bug in the grml [[http://linuxtage.at/|GLT06]] release not yet mentioned on this page? [[http://grml.org/bugs/|Please report it!]] (Please don't forget to add your name and mailadress so we contact you if we have further questions.)
 +
 +==== losetup ====
 +
 +  *  Due to problems with losetup on unionfs it is not possible to create a loop device with files on the live-cd _EXCEPT_ if the file is in /home/grml, /tmp or /ramdisk. You'll notice an error like 'ioctl: LOOP_SET_FD: Invalid argument' [mika]
 +    * Notice: this is not a grml specific problem. See INSTALL file in unionfs sources: "If you want to use losetup, then you need to define -DSUPPORT_BROKEN_LOSETUP. You will be able to use it read-only, but when you try to use it read-write, you will get an Oops.  This should eventually be fixed when we have our own address-space operations (so that we can support sendfile)." [mika]
 +
 +==== isolinux fails with 'Could not find kernel image: grml' ====
 +
 +  * Another warning you might get is 'Unknown keyword in config file'. Your BIOS seems to be broken. The problem has been [[http://syslinux.zytor.com/archives/2006-April/006784.html|reported to isolinux/syslinux upstream]]. Try to boot with 'linux26'. If this still does not work try to boot via [[http://btmgr.webframe.org/|btmgr]]. [Notice taken from [[problems|problems-webpage]]] [mika]
 +
 +==== some PCMCIA WLAN cards don't work out of the box ====
 +
 +  * Deprecated pcmcia-cs was removed with grml 0.6. Now pcmcia¬≠utils is state-of-the-art. Some kernel drivers (like for example PCMCIA WLAN cards) are not autoloaded by default now. They should work anyway by loading the module manually. Run for example 'hwinfo --netcard' to figure out which network module has to be loaded. (Some more information regarding the device is available via 'udevinfo -a -p /sys/class/net/eth0/'). [mika]
 
grml_glt06.txt · Last modified: 2011/10/13 23:55 (external edit)
 
Recent changes RSS feed Creative Commons License Valid XHTML 1.0 Valid CSS Grml homepage Driven by DokuWiki